
<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# " class="h-100">
<head>
<meta charset="utf-8" />
<script async src="/sites/default/files/google_analytics/gtag.js?qwcee0"></script>
<script>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments)};gtag("js", new Date());gtag("config", "UA-148500600-5", {"groups":"default","anonymize_ip":true});</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&amp;l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KC6MRRD');
</script>
<style>/* @see https://github.com/aFarkas/lazysizes#broken-image-symbol */.js img.lazyload:not([src]) { visibility: hidden; }/* @see https://github.com/aFarkas/lazysizes#automatically-setting-the-sizes-attribute */.js img.lazyloaded[data-sizes=auto] { display: block; width: 100%; }</style>
<link rel="canonical" href="https://businesschief.asia/leadership-and-strategy/primeglobal-tripling-apac-business-twelve-months" />
<meta http-equiv="content-language" content="en" />
<meta name="description" content="Though a mix of inorganic and organic growth, PrimeGlobal achieved a record 247% growth in 2020-2021 
PrimeGlobal: Tripling APAC Business in Twelve Months" />
<meta name="keywords" content="ProfessionalServices, LeaderandStrategy, PrimeGlobal, growth" />
<meta property="og:site_name" content="Business Chief APAC" />
<meta property="og:type" content="daily_story" />
<meta property="og:url" content="https://businesschief.asia/leadership-and-strategy/primeglobal-tripling-apac-business-twelve-months" />
<meta property="og:title" content="PrimeGlobal: Tripling APAC Business in Twelve Months  | Leadership &amp; Strategy | Business Chief APAC" />
<meta property="og:description" content="Though a mix of inorganic and organic growth, PrimeGlobal achieved a record 247% growth in 2020-2021" />
<meta property="og:image" content="https://businesschief.asia/sites/default/files/styles/ma/public/image/GettyImages-1260752753.jpg?itok=JpkNFF4Z" />
<meta property="og:image:url" content="https://businesschief.asia/sites/default/files/styles/ma/public/image/GettyImages-1260752753.jpg?itok=JpkNFF4Z" />
<meta property="article:tag" content="ProfessionalServices" />
<meta property="article:tag" content="LeaderandStrategy" />
<meta property="article:tag" content="PrimeGlobal" />
<meta property="article:tag" content="growth" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Though a mix of inorganic and organic growth, PrimeGlobal achieved a record 247% growth in 2020-2021" />
<meta name="twitter:title" content="PrimeGlobal: Tripling APAC Business in Twelve Months" />
<meta name="twitter:url" content="https://businesschief.asia/leadership-and-strategy/primeglobal-tripling-apac-business-twelve-months" />
<meta name="twitter:image" content="https://businesschief.asia/sites/default/files/styles/ma/public/image/GettyImages-1260752753.jpg?itok=JpkNFF4Z" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="shortcut icon" href="https://businesschief.asia/sites/default/files/styles/ma/public/brand-images/android-chrome-512x512_3.png?itok=szCxCkRM" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://businesschief.asia/leadership-and-strategy/primeglobal-tripling-apac-business-twelve-months" />
<script>window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};</script>
<title>PrimeGlobal: Tripling APAC Business in Twelve Months</title>
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_Bmv8wOdee8O3-8PJdNoumCXrNyZCTkznXGZsqhoBGeo.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_4GUGQmJ0tK_gf13CVsMQp-UPo0e99B-AiiwfGhNXuzM.css" />
<link rel="stylesheet" media="all" href="/themes/custom/bizclik_sites/dist/main.min.css?qwcee0" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_wpfhIIbcj5xjdHDed5COq0rPsZnJbZQR12hgQxYuDq4.css" />
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="path-node page-node-type-daily-story    bg- d-flex flex-column h-100">
<div class="loader"></div>
<a href="#main-content" class="visually-hidden focusable skip-link">
Skip to main content
</a>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KC6MRRD" height="0" width="0" style="display:none;visibility:hidden;"></iframe>
</noscript>
<div class="dialog-off-canvas-main-canvas d-flex flex-column h-100" data-off-canvas-main-canvas>
<div class="page-wrapper business_chief_apac">
<div class="custom-overlay"></div>
<div class="form-overlay"></div>
<header role="banner" class="header">
<div class="top-header">
<div class="top-header-left">
<div class="logo-region">
<div class="region region-logo-region">
<div id="block-sitebranding" class="site-branding block block-system block-system-branding-block">
<div class="site-brand">
<a href="/" title="Home" rel="home" class="site-logo">
<img src="https://businesschief.asia/sites/default/files/styles/ma/public/brand-images/BusinessCheif-White_1.png?itok=wDWG6Dmf" alt="Home" />
</a>
</div>
</div>
</div>
</div>
<nav class="navbar navbar-region">
<div class="navbar-collapse" id="navbarSupportedContent">
<div class="region region-navbar">
<div id="block-brandswitcher" class="brand-switcher header-switcher block block-bizclik-brands block-brand-switcher-block">
<div class="dropdown show">
<a class="btn btn-secondary dropdown-toggle" href="https://businesschief.asia/" role="button" id="dropdownBrand" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
Business Chief APAC
</a>
<div class="dropdown-menu" aria-labelledby="dropdownBrand">
<a class="dropdown-item" target="_blank" href="https://aimagazine.com/">AI Magazine</a>
<a class="dropdown-item" target="_blank" href="https://businesschief.eu/">Business Chief EMEA</a>
<a class="dropdown-item" target="_blank" href="https://businesschief.com/">Business Chief North America</a>
<a class="dropdown-item" target="_blank" href="https://constructionglobal.com/">Construction Global</a>
<a class="dropdown-item" target="_blank" href="https://cybermagazine.com/">Cyber Magazine</a>
<a class="dropdown-item" target="_blank" href="https://datacentremagazine.com/">Data Centre Magazine</a>
<a class="dropdown-item" target="_blank" href="https://energydigital.com/">Energy Digital</a>
<a class="dropdown-item" target="_blank" href="https://fintechmagazine.com/">FinTech Magazine</a>
<a class="dropdown-item" target="_blank" href="https://fooddigital.com/">Food Digital</a>
<a class="dropdown-item" target="_blank" href="https://healthcareglobal.com/">Healthcare Global</a>
<a class="dropdown-item" target="_blank" href="https://insurtechdigital.com/">InsurTech Magazine</a>
<a class="dropdown-item" target="_blank" href="https://manufacturingglobal.com/">Manufacturing Global</a>
<a class="dropdown-item" target="_blank" href="https://miningglobal.com/">Mining Global</a>
<a class="dropdown-item" target="_blank" href="https://mobile-magazine.com/">Mobile Magazine</a>
<a class="dropdown-item" target="_blank" href="https://procurementmag.com/">Procurement</a>
<a class="dropdown-item" target="_blank" href="https://supplychaindigital.com/">Supply Chain Digital</a>
<a class="dropdown-item" target="_blank" href="https://sustainabilitymag.com/">Sustainability Magazine</a>
<a class="dropdown-item" target="_blank" href="https://technologymagazine.com/">Technology</a>
</div>
</div>
</div>
<div id="block-regionswitcher" class="region-switcher header-switcher block block-bizclik-brands block-region-switcher-block">
<div class="dropdown show">
<a class="btn btn-secondary dropdown-toggle" href="/region/any" role="button" id="dropdownRegion" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
All
</a>
<div class="dropdown-menu" aria-labelledby="dropdownRegion">
<a class="dropdown-item" href="/region/asia">Asia</a>
<a class="dropdown-item" href="/region/eu">Europe</a>
<a class="dropdown-item" href="/region/uk">United Kingdom</a>
<a class="dropdown-item" href="/region/usa">Usa</a>
</div>
</div>
</div>
</div>
</div>
</nav>
</div>
<div class="top-header-right">
<div class="latest-issue-region">
<div class="region region-latest-issue-region">
<div class="views-element-container header-latest-issue block block-views block-views-blocklatest-issue-out-now-latest-issue" id="block-views-block-latest-issue-out-now-latest-issue">
<h2>Latest issue out now</h2>
<div><div class="latest-issue view view-latest-issue-out-now view-id-latest_issue_out_now view-display-id-latest_issue js-view-dom-id-075cdc24a6c853114ab431dae5b6e723c4b4018a5b743ade404020b181dbfcc0">
<div class="view-content">
<div class="views-row">
<div data-history-node-id="166681" role="article" about="https://businesschief.asia/magazine/business-chief-apac/june-2021" title="June 2021" description="Similar results" class="node node--type-magazine node--view-mode-small-preview">
<div class="magazines-block">
<div class="magazines-cover">
<a class="magazine-link-button" href="/magazine-read/166681" rel="bookmark">
<div class="field field--name-field-magazine-cover field--type-entity-reference field--label-hidden field__item"><article class="media media--type-image media--view-mode-_-10-crop">
<div class="field field--name-field-media-image field--type-image field--label-hidden field__item"> <img width="300" height="424" alt="" loading="lazy" class="lazyload image-style-_-10-crop" data-src="/sites/default/files/styles/7_10_crop/public/image/bc%20apac%20june.jpg?itok=xTZoqEFD" typeof="foaf:Image" />
</div>
</article>
</div>
</a>
</div>
<div class="magazine-link">
<a class="magazine-link-button" href="/magazine-read/166681" rel="bookmark">
Read now
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="views-exposed-form header-search block block-views block-views-exposed-filter-blocksearch-page-1" data-drupal-selector="views-exposed-form-search-page-1" id="block-search">
<h2>Search results</h2>
<form action="/search" method="get" id="views-exposed-form-search-page-1" accept-charset="UTF-8">
<div class="form--inline clearfix">
<div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-query form-item-query form-no-label">
<input placeholder="Search for content" data-drupal-selector="edit-query" type="text" id="edit-query" name="query" value="" size="30" maxlength="128" class="form-text form-control" />
</div>
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions">
<input data-drupal-selector="edit-submit-search" type="submit" id="edit-submit-search" value="Apply" class="button js-form-submit form-submit btn btn-primary" />
</div>
</div>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="bottom-header">
<div class="block-button">
<a type="button" class="button button-get-tickets" data-toggle="modal" data-target=".bd-example-modal-lg">GET TICKETS</a>
</div>
<div class="burger-btn">Open/Close</div>
<div class="bottom-header-region">
<div class="navigation-region">
<div class="region region-navigation-region">
<nav role="navigation" aria-labelledby="block-sitemenu-menu" id="block-sitemenu" class="main-menu block block-menu navigation menu--site-menu">
<h5 class="visually-hidden" id="block-sitemenu-menu">Site menu</h5>
<ul class="menu">
<li class="menu-item">
<a href="/interviews" data-drupal-link-system-path="interviews">Interviews</a>
</li>
<li class="menu-item menu-item--expanded">
<span> Categories </span>
<ul class="menu">
<li position="1" class="menu-item">
<a href="https://businesschief.asia/topics/leadership-and-strategy" data-drupal-link-system-path="taxonomy/term/65105">Leadership &amp; Strategy</a>
</li>
<li position="2" class="menu-item">
<a href="https://businesschief.asia/topics/corporate-finance" data-drupal-link-system-path="taxonomy/term/65104">Corporate Finance</a>
</li>
<li position="3" class="menu-item">
<a href="https://businesschief.asia/topics/technology" data-drupal-link-system-path="taxonomy/term/65107">Technology</a>
</li>
<li position="4" class="menu-item">
<a href="https://businesschief.asia/topics/digital-strategy" data-drupal-link-system-path="taxonomy/term/65106">Digital Strategy</a>
</li>
<li position="5" class="menu-item">
<a href="https://businesschief.asia/topics/human-capital" data-drupal-link-system-path="taxonomy/term/65108">Human Capital</a>
</li>
<li position="6" class="menu-item">
<a href="https://businesschief.asia/topics/sustainability" data-drupal-link-system-path="taxonomy/term/65109">Sustainability</a>
</li>
</ul>
<div class="open-sub-menu">
<svg width="12" height="8" viewBox="0 0 12 8" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M1.41 0.589844L6 5.16984L10.59 0.589844L12 1.99984L6 7.99984L0 1.99984L1.41 0.589844Z" fill="white" />
</svg>
</div>
</li>
<li class="menu-item">
<a href="/company_listings" data-drupal-link-system-path="company_listings">Companies</a>
</li>
<li class="menu-item">
<a href="/top_10" data-drupal-link-system-path="top_10">Lists</a>
</li>
<li class="menu-item">
<a href="/videos" data-drupal-link-system-path="videos">Videos</a>
</li>
<li class="menu-item">
<a href="/events" data-drupal-link-system-path="events">Events</a>
</li>
<li class="menu-item menu-item--expanded">
 <span> Magazine </span>
<ul class="menu">
<li class="menu-item">
<a href="/magazine" data-drupal-link-system-path="magazine">Current Magazine</a>
</li>
<li class="menu-item">
<a href="/backIssues" data-drupal-link-system-path="backIssues">Back Issues</a>
</li>
</ul>
<div class="open-sub-menu">
<svg width="12" height="8" viewBox="0 0 12 8" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M1.41 0.589844L6 5.16984L10.59 0.589844L12 1.99984L6 7.99984L0 1.99984L1.41 0.589844Z" fill="white" />
</svg>
</div>
</li>
<li class="menu-item menu-item--expanded">
<span>LIVE</span>
</li>
</ul>
</nav>
</div>
</div>
<div class="socials-region">
<div class="region region-socials-region">
<nav role="navigation" aria-labelledby="block-social-menu" id="block-social" class="header-socials socials-block block block-menu navigation menu--social">
<h5 class="visually-hidden" id="block-social-menu">Social</h5>
<ul class="menu">
<li class="menu-item">
<a href="https://www.linkedin.com/company/business-chief" target="_blank" rel="noopener">LinkedIN</a>
</li>
<li class="menu-item">
<a href="https://twitter.com/Business_Chief" target="_blank" rel="noopener">Twitter</a>
</li>
<li class="menu-item">
<a href="https://www.facebook.com/BusinessChief/" target="_blank" rel="noopener">Facebook</a>
</li>
<li class="menu-item">
<a href="https://www.instagram.com/businesschiefmag/" target="_blank" rel="noopener">Instagram</a>
</li>
<li class="menu-item">
<a href="https://www.youtube.com/channel/UCqOWUeWYNzHf6LvgETw3S1Q" target="_blank" rel="noopener">Youtube</a>
</li>
<li class="menu-item">
<a href="https://medium.com/business-chief" target="_blank" rel="noopener">Meduim</a>
</li>
</ul>
</nav>
</div>
</div>
</div>
</div>
</header>
<main role="main" class="main-content">
<a id="main-content" tabindex="-1"></a>
<div class="region region-content">
<div data-drupal-messages-fallback class="hidden"></div>
<div id="block-mainpagecontent" class="block block-system block-system-main-block">
<div data-history-node-id="169314" role="article" about="https://businesschief.asia/leadership-and-strategy/primeglobal-tripling-apac-business-twelve-months" title="PrimeGlobal: Tripling APAC Business in Twelve Months" description="Though a mix of inorganic and organic growth, PrimeGlobal achieved a record 247% growth in 2020-2021 
PrimeGlobal: Tripling APAC Business in Twelve Months" class="node node--type-daily-story node--view-mode-featured">
<div class="node-title">
<h2>
<a href="https://businesschief.asia/leadership-and-strategy/primeglobal-tripling-apac-business-twelve-months" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden"> PrimeGlobal: Tripling APAC Business in Twelve Months
</span>
</a>
</h2>
</div>
<div class="node__content">
<div class="layout layout--twocol-section layout--twocol-section--50-50" id="main-banner">
<div class="layout__region layout__region--first">
<div class="block block-layout-builder block-field-blocknodedaily-storyfield-media-image">
<div class="field field--name-field-media-image field--type-entity-reference field--label-hidden field__item"><article class="media media--type-image media--view-mode-_-3-crop">
<div class="field field--name-field-media-image field--type-image field--label-hidden field__item"> <img width="2540" height="1123" alt="" loading="lazy" class="lazyload image-style-_-3-crop" data-src="/sites/default/files/styles/8_3_crop/public/image/GettyImages-1260752753.jpg?itok=eZ45SDBX" typeof="foaf:Image" />
</div>
</article>
</div>
</div>
</div>
<div class="layout__region layout__region--second">
<div class="block block-layout-builder block-field-blocknodedaily-storyfield-category">
<div class="field field--name-field-category field--type-entity-reference field--label-hidden field__item"><a href="https://businesschief.asia/topics/leadership-and-strategy" hreflang="en">Leadership &amp; Strategy</a></div>
</div>
<div class="block block-layout-builder block-field-blocknodedaily-storycreated">
<span class="field field--name-created field--type-created field--label-hidden">Jul 16, 2021</span>
</div>
<div class="block block-layout-builder block-field-blocknodedaily-storyfield-author-name">
<div class="field field--name-field-author-name field--type-string field--label-hidden field__item">
Elise Leise
</div>
</div>
<div class="block block-layout-builder block-field-blocknodedaily-storytitle">
<span class="field field--name-title field--type-string field--label-hidden"> <h1>PrimeGlobal: Tripling APAC Business in Twelve Months </h1>
</span>
</div>
<div class="block block-layout-builder block-field-blocknodedaily-storyfield-featured">
<div class="field field--name-field-featured field--type-boolean field--label-hidden field__item">Featured Article</div>
</div>
<div class="block block-layout-builder block-field-blocknodedaily-storyfield-tags">
<div class="field field--name-field-tags field--type-entity-reference field--label-hidden field__items">
<div class="field__item">ProfessionalServices</div>
<div class="field__item">LeaderandStrategy</div>
<div class="field__item">PrimeGlobal</div>
<div class="field__item">growth</div>
</div>
</div>
</div>
</div>
<div class="layout layout--twocol-section layout--twocol-section--75-25" id="twocol-section-info">
<div class="layout__region layout__region--first">
<div class="block block-layout-builder block-field-blocknodedaily-storyfield-stand-first">
<div class="field field--name-field-stand-first field--type-string field--label-hidden field__item">Though a mix of inorganic and organic growth, PrimeGlobal achieved a record 247% growth in 2020-2021</div>
</div>
<div class="block block-layout-builder block-field-blocknodedaily-storyfield-body-copy">
<div class="clearfix text-formatted field field--name-field-body-copy field--type-text-long field--label-hidden field__item"><p><span><span><span><span><span><span>In one of the most disruptive years for business to date, how does </span></span></span></span></span></span><a href="https://www.primeglobal.net/"><span><span><span><span><span><span><span><span>PrimeGlobal</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>, a professional services organization, end up tripling its revenue? The company reported double-digit growth with a revenue of over </span></span></span></span></span></span><a href="https://www.primeglobal.net/news/primeglobal-reports-unprecedented-growth"><span><span><span><span><span><span><span><span>US$3.5bn</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span> for this fiscal year; its staff grew by </span></span></span></span></span></span><a href="https://www.primeglobal.net/news/primeglobal-reports-unprecedented-growth"><span><span><span><span><span><span><span><span>21% to 21,000+ team members</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>; and its number of partners grew </span></span></span></span></span></span><a href="https://www.primeglobal.net/news/primeglobal-reports-unprecedented-growth"><span><span><span><span><span><span><span><span>41% to over 3,000</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>.</span></span></span></span></span></span></p>
<p><span><span><span><span><span><span>‘Our unique culture of learning, sharing, and collaboration continues to attract new, strong, independent firms to PrimeGlobal’, </span></span></span></span></span></span><a href="https://www.consultancy.asia/news/4295/primeglobal-more-than-tripled-its-apac-business-in-past-year"><span><span><span><span><span><span><span><span>said CEO Steve Heathcote</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>. ‘And I am so proud of our member firms who have been by their clients’ side throughout the pandemic. We came together to learn and respond to changing needs’. </span></span></span></span></span></span></p>
<h2><span><span><span><span><span><span>What Led to Its Success?</span></span></span></span></span></span></h2>
<p><span><span><span><span><span><span>Fundamentally, the pandemic meant that businesses needed PrimeGlobal’s advisors. But the company also launched an aggressive inorganic drive for new member firms. In 2020 and 2021, </span></span></span></span></span></span><a href="https://www.consultancy.asia/news/4295/primeglobal-more-than-tripled-its-apac-business-in-past-year"><span><span><span><span><span><span><span><span>eleven new APAC firms joined PrimeGlobal</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>, including one of China’s largest professional services firms, </span></span></span></span></span></span><a href="https://www.primeglobal.net/firms/zhongxinghua"><span><span><span><span><span><span><span><span>ZhongXingHua</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>. That firm alone added </span></span></span></span></span></span><a href="https://www.consultancy.asia/news/4295/primeglobal-more-than-tripled-its-apac-business-in-past-year"><span><span><span><span><span><span><span><span>2,700+</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span> finance professionals and </span></span></span></span></span></span><a href="https://www.consultancy.asia/news/4295/primeglobal-more-than-tripled-its-apac-business-in-past-year"><span><span><span><span><span><span><span><span>32 offices</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span> to PrimeGlobal’s ASEAN community. In addition, PG added </span></span></span></span></span></span><a href="https://www.primeglobal.net/news/frank-recovery-joins-primeglobal"><span><span><span><span><span><span><span><span>Hong Kong’s Frank Forensic Corporate Recovery</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>, </span></span></span></span></span></span><a href="https://www.primeglobal.net/firms/promaudit"><span><span><span><span><span><span><span><span>Uzbekistan’s Prom Audit</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>, </span></span></span></span></span></span><a href="https://www.primeglobal.net/firms/tp-adhikari-associates"><span><span><span><span><span><span><span><span>Nepal’s TP Adhikari</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>, and new firms from Pakistan, Singapore, and China. </span></span></span></span></span></span></p>
<p><span><span><span><span><span><span>As a result...</span></span></span></span></span></span><a href="https://www.primeglobal.net/news/primeglobal-reports-unprecedented-growth"><span><span><span><span><span><span><span><span>247% growth in APAC</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>!</span></span></span></span></span></span></p>
<h2><span><span><span><span><span><span>Where Will PrimeGlobal Go From Here? </span></span></span></span></span></span></h2>
<p><span><span><span><span><span><span>The firm recently launched </span></span></span></span></span></span><a href="https://www.primeglobal.net/primeglobal-strategy2025-"><span><span><span><span><span><span><span><span>Strategy 2025</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>, which lays out a roadmap for how PrimeGlobal will realise its vision, mission, and purpose. The company involved its entire community in shaping the project, holding roundtables, talks, and consultations with </span></span></span></span></span></span><a href="https://www.primeglobal.net/primeglobal-strategy2025-"><span><span><span><span><span><span><span><span>90% of its member firms</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>. Further, the company is focused on organic growth and recruitment in its Greater China and ASEAN regions. </span></span></span></span></span></span></p>
<p><span><span><span><span><span><span>‘As the pace of change quickens, we’ve anticipated how firms will need to be supported in the future’, </span></span></span></span></span></span><a href="https://www.primeglobal.net/news/primeglobal-reports-unprecedented-growth"><span><span><span><span><span><span><span><span>said Heathcote</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>. PrimeGlobal intends to increase its staff, partners, and facilities across all four of its global locations. </span></span></span></span></span></span><a href="https://www.primeglobal.net/news/primeglobal-reports-unprecedented-growth"><span><span><span><span><span><span><span><span>To conclude courtesy of Heathcote</span></span></span></span></span></span></span></span></a><span><span><span><span><span><span>: ‘Our Strategy 2025 will ensure our firms are ready to re-tool, re-skill, and re-set to help businesses thrive as we emerge from the pandemic’. </span></span></span></span></span></span></p></div>
</div>
<div class="block block-layout-builder block-extra-field-blocknodedaily-storylink-action-button-text-first">
<section class="action-button-text">
<a class="action-link" target="_blank" rel="noopener noreferrer" href="https://www.linkedin.com/company/business-chief/">
<button>LinkedIn</button>
</a>
<span class="action-text">Follow us on LinkedIn</span>
</section>
</div>
<div class="block block-layout-builder block-extra-field-blocknodedaily-storylink-action-button-text-second">
<section class="action-button-text">
<a class="action-link" target="_blank" rel="noopener noreferrer" href="https://businesschief.asia/magazine">
<button>Read Now</button>
</a>
<span class="action-text">The latest issue of Business Chief magazine</span>
</section>
</div>
<div class="block block-addtoany block-addtoany-block">
<h2>Share article</h2>
<span class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://businesschief.asia/leadership-and-strategy/primeglobal-tripling-apac-business-twelve-months" data-a2a-title="PrimeGlobal: Tripling APAC Business in Twelve Months "><a class="a2a_button_linkedin"></a><a class="a2a_button_twitter"></a><a class="a2a_button_facebook"></a></span>
</div>
</div>
<div class="layout__region layout__region--second">
<div class="block block-bizclik-site block-customgamwblock">
<div id="gamw_3769dec5-e35d-4bce-afcc-cd39e81ec13c" data-uuid="3769dec5-e35d-4bce-afcc-cd39e81ec13c" data-ad-unit="bcaparticlepage_300x600"></div>
</div>
<div class="block block-bizclik-site block-customgamwblock">
<div id="gamw_ac39b20b-a986-418b-805e-a49b3f623486" data-uuid="ac39b20b-a986-418b-805e-a49b3f623486" data-ad-unit="bcaparticlepage_300x250"></div>
</div>
</div>
</div>
<div class="layout layout--onecol" id="also-like">
<div class="layout__region layout__region--content">
<div class="views-element-container block block-views block-views-blockalso-like-block-also-like">
<div class="views-element-container"><div class="view view-also-like-block view-id-also_like_block view-display-id-also_like js-view-dom-id-dbdcfb17430a075a4601f108f2cb7fa702c01a7594f6341543ce831434faed51">
<div class="title">
<h2>You might also like these articles</h2>
</div>
<div class="view-content">
<div class="views-row"><div class="views-field views-field-field-media-image"><div class="field-content"><article class="media media--type-image media--view-mode-_-3-crop">
<div class="field field--name-field-media-image field--type-image field--label-hidden field__item"> <img width="2540" height="953" alt="Business Hotels" title="Top 10 Business Hotels in Asia" loading="lazy" class="lazyload image-style-_-3-crop" data-src="/sites/default/files/styles/8_3_crop/public/image/dayana-brooke-dZbBlss3FyE-unsplash.jpg?h=a80b0702&amp;itok=7aiWgKr3" typeof="foaf:Image" />
</div>
</article>
</div></div><div class="views-field views-field-nothing"><span class="field-content"><div class="node-title"><a href="https://businesschief.asia/top10/top-10-business-hotels-asia" hreflang="en">Top 10 Business Hotels in Asia</a></div>
<div class="author-category">
<div class="node-author">
Sajana Samarasinghe
</div>
<div class="node-category">
Human Capital
</div>
</div></span></div></div>
<div class="views-row"><div class="views-field views-field-field-media-image"><div class="field-content"><article class="media media--type-image media--view-mode-_-3-crop">
<div class="field field--name-field-media-image field--type-image field--label-hidden field__item"> <img width="1562" height="585" alt="" loading="lazy" class="lazyload image-style-_-3-crop" data-src="/sites/default/files/styles/8_3_crop/public/image/Untitled%20design_3.jpg?h=c5e78ed1&amp;itok=SPP3uFLo" typeof="foaf:Image" />
</div>
</article>
</div></div><div class="views-field views-field-nothing"><span class="field-content"><div class="node-title"><a href="https://businesschief.asia/top10/top-12-rising-female-business-leaders-asia" hreflang="en">Top 12 rising female business leaders in Asia</a></div>
<div class="author-category">
<div class="node-author">
Kate Birch
</div>
<div class="node-category">
Leadership &amp; Strategy
</div>
</div></span></div></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="layout layout--onecol" id="ad-banner">
<div class="layout__region layout__region--content">
<div class="block block-bizclik-site block-customgamwblock">
<div id="gamw_39b27d84-d362-4407-80da-645186b76c3e" data-uuid="39b27d84-d362-4407-80da-645186b76c3e" data-ad-unit="bcaparticlepage_970x250"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="block-gamwpopupblock" class="block block-bizclik-site block-gamwpopupblock">
<div class="advertisement business_chief_apac" id="business_chief_apac">
<div class="banner-wrapper">
<div id="gamw_64536e85-980d-4230-9279-079a6e31b381" data-uuid="64536e85-980d-4230-9279-079a6e31b381" data-ad-unit="bcap_1920x1080"></div>
</div>
<div class="group-wrapper">
<div class="group-left">
<span>Powered by</span>
<img src="https://businesschief.asia/sites/default/files/styles/ma/public/brand-images/BusinessCheif-White_1.png?itok=wDWG6Dmf" alt="logo" />
</div>
<div class="group-right">
<a class="btn-link" href="https://businesschief.asia/leadership-and-strategy/primeglobal-tripling-apac-business-twelve-months">Join our community</a>
</div>
</div>
<div class="btn-close">Close</div>
</div>
</div>
</div>
</main>
<footer role="contentinfo" class="footer">
<div class="footer-region">
<div class="left-footer-region">
<div class="region region-left-footer-region">
<div id="block-footer-logo" class="footer-site-branding block block-system block-system-branding-block">
<div class="site-brand">
<a href="/" title="Home" rel="home" class="site-logo">
<img src="https://businesschief.asia/sites/default/files/styles/ma/public/brand-images/BusinessCheif-White_1.png?itok=wDWG6Dmf" alt="Home" />
</a>
</div>
</div>
<nav role="navigation" aria-labelledby="block-social-2-menu" id="block-social-2" class="footer-socials footer-socials-mobile socials-block block block-menu navigation menu--social">
<h5 class="visually-hidden" id="block-social-2-menu">Social</h5>
<ul class="menu">
<li class="menu-item">
<a href="https://www.linkedin.com/company/business-chief" target="_blank" rel="noopener">LinkedIN</a>
</li>
<li class="menu-item">
<a href="https://twitter.com/Business_Chief" target="_blank" rel="noopener">Twitter</a>
</li>
<li class="menu-item">
<a href="https://www.facebook.com/BusinessChief/" target="_blank" rel="noopener">Facebook</a>
</li>
<li class="menu-item">
<a href="https://www.instagram.com/businesschiefmag/" target="_blank" rel="noopener">Instagram</a>
</li>
<li class="menu-item">
<a href="https://www.youtube.com/channel/UCqOWUeWYNzHf6LvgETw3S1Q" target="_blank" rel="noopener">Youtube</a>
</li>
<li class="menu-item">
<a href="https://medium.com/business-chief" target="_blank" rel="noopener">Meduim</a>
</li>
</ul>
</nav>
<nav role="navigation" aria-labelledby="block-sitefootermenu-menu" id="block-sitefootermenu" class="footer-main-menu footer-menu block block-menu navigation menu--site-footer-menu">
<h5 class="visually-hidden" id="block-sitefootermenu-menu">Site footer menu</h5>
<ul class="menu">
<li class="menu-item">
<a href="/magazine" data-drupal-link-system-path="magazine">Magazine</a>
</li>
<li class="menu-item">
<a href="/company_listings" data-drupal-link-system-path="company_listings">Companies</a>
</li>
<li class="menu-item">
<a href="/videos" data-drupal-link-system-path="videos">Videos</a>
</li>
<li class="menu-item">
<a href="/events" data-drupal-link-system-path="events">Events</a>
</li>
<li class="menu-item">
<a href="/top_10" data-drupal-link-system-path="top_10">Lists</a>
</li>
</ul>
</nav>
<nav role="navigation" aria-labelledby="block-sitesecondmenufooter-menu" id="block-sitesecondmenufooter" class="footer-second-menu footer-menu block block-menu navigation menu--site-second-menu-footer">
<h5 class="visually-hidden" id="block-sitesecondmenufooter-menu">Site second menu footer</h5>
<ul class="menu">
<li class="menu-item">
<a href="/about_us" data-drupal-link-system-path="about_us">About us</a>
</li>
<li class="menu-item">
<a href="/contact_us" data-drupal-link-system-path="contact_us">Contact us</a>
</li>
<li class="menu-item">
<a href="/advertise" data-drupal-link-system-path="advertise">Advertise</a>
</li>
<li class="menu-item">
<a href="/press-release" data-drupal-link-system-path="press-release">Press Releases</a>
</li>
<li class="menu-item">
<a href="/pr_newswire" data-drupal-link-system-path="pr_newswire">PR Newswire</a>
</li>
</ul>
</nav>
<div id="block-poweredby" class="copyright-powered-by block block-block-content block-block-content66344e09-fa52-41cf-9cfb-6d5aa40df2e7">

<div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><div class="powered-by">
<div class="powered-by-title">
<p>Powered by</p>
</div>
<div class="logo-advertise">
<div class="powered-by-logo"><a href="https://www.bizclikmedia.com/contact" rel="noopener" target="_blank"><img alt="BizClik Media" src="/themes/custom/bizclik_sites/bizclik-logo.svg" /></a></div>
<div class="powered-by-advertise"><a href="https://www.bizclikmedia.com/contact" rel="noopener" target="_blank">Advertise with BizClik</a></div>
</div>
<div class="policy">© 2021&nbsp;BizClik Media Limited, All Rights Reserved. <a href="/termsOfUse">User Agreement</a> and <a href="/privacy_policy">Privacy Policy</a></div>
</div>
</div>
</div>
</div>
</div>
<div class="right-footer-region">
<div class="region region-right-footer-region">
<nav role="navigation" aria-labelledby="block-footer-social-menu" id="block-footer-social" class="footer-socials footer-socials-desktop socials-block block block-menu navigation menu--social">
<h5 class="visually-hidden" id="block-footer-social-menu">Social</h5>
<ul class="menu">
<li class="menu-item">
<a href="https://www.linkedin.com/company/business-chief" target="_blank" rel="noopener">LinkedIN</a>
</li>
<li class="menu-item">
<a href="https://twitter.com/Business_Chief" target="_blank" rel="noopener">Twitter</a>
</li>
<li class="menu-item">
<a href="https://www.facebook.com/BusinessChief/" target="_blank" rel="noopener">Facebook</a>
</li>
<li class="menu-item">
<a href="https://www.instagram.com/businesschiefmag/" target="_blank" rel="noopener">Instagram</a>
</li>
<li class="menu-item">
<a href="https://www.youtube.com/channel/UCqOWUeWYNzHf6LvgETw3S1Q" target="_blank" rel="noopener">Youtube</a>
</li>
<li class="menu-item">
<a href="https://medium.com/business-chief" target="_blank" rel="noopener">Meduim</a>
</li>
</ul>
</nav>
<div id="block-footersiteinfoandlatestmagazine" class="footer-site-info block block-bizclik-site block-footersiteinfo">
<div class="latest-magazine">
<div class="views-element-container"><div class="latest-issue view view-footer-latest-issue-out-now view-id-footer_latest_issue_out_now view-display-id-latest_issue js-view-dom-id-d26656436a1e08de1d003b23e05c2371026e617b8899109f9bc442cb82e77fcb">
<div class="view-content">
<div class="views-row"><div class="views-field views-field-nothing"><span class="field-content"><div class="magazines-block">
<div class="magazines-cover">
<a class="magazine-link-button" href="/magazine">
<article class="media media--type-image media--view-mode-_-10-crop">
<div class="field field--name-field-media-image field--type-image field--label-hidden field__item"> <img width="300" height="424" alt="" loading="lazy" class="lazyload image-style-_-10-crop" data-src="/sites/default/files/styles/7_10_crop/public/image/bc%20apac%20june.jpg?itok=xTZoqEFD" typeof="Image" />
</div>
</article>
</a>
</div>
<div class="magazine-link">
<a class="magazine-link-button" href="/magazine" rel="bookmark">
Read now
</a>
</div>
</div></span></div></div>
</div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-name">
Business Chief APAC
</div>
<div class="site-description">
Business Chief APAC
</div>
</div>
</div>
</div>
</div>
</div>
<div class="modal fade bd-example-modal-lg" tabindex="-1" role="dialog" aria-labelledby="myLargeModalLabel" aria-hidden="true">
<div class="modal-dialog modal-lg">
<div class="modal-content">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal" aria-label="Close">
<span aria-hidden="true">&times;</span>
</button>
</div>
<div id="eventbrite-widget-container-"></div>
</div>
</div>
</div>
</footer>
</div>
</div>
<!--[if lte IE 8]>
<script src="/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->
<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/169314","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ajaxPageState":{"libraries":"addtoany\/addtoany,bizclik_site\/bizclik_site,bizclik_sites\/global-styling,bootstrap4\/bootstrap4-js-latest,bootstrap4\/global-styling,classy\/base,classy\/messages,classy\/node,core\/html5shiv,core\/normalize,gamw\/ad,genpass\/genpass,google_analytics\/google_analytics,layout_builder\/twocol_section,layout_discovery\/onecol,lazy\/lazy,system\/base,views\/views.module","theme":"bizclik_sites","theme_token":null},"ajaxTrustedUrl":{"\/search":true},"google_analytics":{"account":"UA-148500600-5","trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip","trackColorbox":1},"lazy":{"lazysizes":{"lazyClass":"lazyload","loadedClass":"lazyloaded","loadingClass":"lazyloading","preloadClass":"lazypreload","errorClass":"lazyerror","autosizesClass":"lazyautosizes","srcAttr":"data-src","srcsetAttr":"data-srcset","sizesAttr":"data-sizes","minSize":40,"customMedia":[],"init":true,"expFactor":1.5,"hFac":0.8,"loadMode":2,"loadHidden":true,"ricTimeout":0,"throttleDelay":125,"plugins":[]},"placeholderSrc":"","preferNative":false},"gamw":{"blocks":{"bcaparticlepage_970x250":{"39b27d84-d362-4407-80da-645186b76c3e":{"uuid":"39b27d84-d362-4407-80da-645186b76c3e","ad_unit":"bcaparticlepage_970x250","sizes":[],"dev_mode":0,"collapsed":0,"targeting_attributes":{"ad_slot":"business_chief_apac_65105","site":"BizClik Media"},"gamw_id":"80843160"}},"bcaparticlepage_300x250":{"ac39b20b-a986-418b-805e-a49b3f623486":{"uuid":"ac39b20b-a986-418b-805e-a49b3f623486","ad_unit":"bcaparticlepage_300x250","sizes":[{"300x250":[300,250]},{"300x250":[300,250]}],"dev_mode":0,"collapsed":0,"targeting_attributes":{"ad_slot":"business_chief_apac_65105","site":"BizClik Media"},"gamw_id":"80843160"}},"bcaparticlepage_300x600":{"3769dec5-e35d-4bce-afcc-cd39e81ec13c":{"uuid":"3769dec5-e35d-4bce-afcc-cd39e81ec13c","ad_unit":"bcaparticlepage_300x600","sizes":[{"300x600":[300,600]},{"300x600":[300,600]}],"dev_mode":0,"collapsed":0,"targeting_attributes":{"ad_slot":"business_chief_apac_65105","site":"BizClik Media"},"gamw_id":"80843160"}},"bcap_1920x1080":{"64536e85-980d-4230-9279-079a6e31b381":{"uuid":"64536e85-980d-4230-9279-079a6e31b381","ad_unit":"bcap_1920x1080","sizes":{"0":{"300x250":[300,250]},"1":{"300x250":[300,250]},"400":{"382x432":[382,432]},"768":{"768x432":[768,432]},"992":{"768x432":[768,432]},"1024":{"768x432":[768,432]},"1440":{"1024x576":[1024,576]},"1600":{"1440x810":[1440,810]},"1920":{"1600x900":[1600,900]},"1970":{"1920x1080":[1920,1080]},"2560":{"1920x1080":[1920,1080]}},"dev_mode":0,"collapsed":0,"targeting_attributes":{"site":"BizClik Media"},"gamw_id":"80843160"}}}},"user":{"uid":0,"permissionsHash":"bc53c7c8b84d9537ceef47c7414dcb13766c886bbe358d44c566768bf9991a0a"}}</script>
<script src="/sites/default/files/js/js_OSiDywuC6bCcPCJFgfV7Y89SnaCq_4-OR0yuqKRXo8U.js"></script>
<script src="https://static.addtoany.com/menu/page.js" async></script>
<script src="/sites/default/files/js/js_6gwYrdcr-53Xpocd0HCE7byCTIkfKDlzxOfheyQBBJs.js"></script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'66fe1c605ce55a7b',m:'1575e18c4eb522fd0bb59d716a7a3cf7c44d508f-1626468711-1800-Aage/wTLXqlGjkooY+cbRgQuEN40cOLauIcgujP7dw9eQX3/E5TuR3fGZsEHjxAacjOftvwUaws3M2IZeML86BjPyFWQVVjfB/K1QRrJ8Bxze7Hu10qirR0MCEbUiC5ccRWGnUjwt2yt/RHaYub//OK6vh9vEZLGm9PKTTKBxgZNmpi+vPT8vl8Np6hiYvYjbqHAZBOcTFFcX/6mygf+c5E=',s:[0xf769167a82,0x98cf5cf637],}})();</script></body>
</html>
